<br /> libstdc++ broken, breaks apt – Debian Planet

Welcome to Debian Planet

News for Debian. Stuff that *really* matters

Debian
These are important Debian sites one should not be without!

  • Official Debian site
  • Package search
  • Mailing list archives
  • Bug reports
  • Debian on CD
  • Debian Weekly News — excellent news source!
  • Unofficial APT sources
    (apt-get.org)

  • Developers’ Corner
  • Community
    Need help? You’re not alone on this planet.

  • debianHELP
    (User support site)

  • Debian International
  • DebianForum.de
    (Deutsch)

  • DebianForum.dk
    (Dansk)

  • EsDebian
    (Español)

  • DebianWorld
    (Français)

  • Debian-Fr
    (Français)

  • MaximumDebian
    (Italiano)

  • DebianUsers
    (Korean)

  • Debian-BR
    (Português)

  • DebianHOWTO (Deutsch)
  • Russian Debian
  • Contribute
    Got that latest or greatest scoop? Perhaps you have some important news for the Debian community? Submit a news item!

    Or perhaps you’ve written a rather ground breaking insight into some aspect of Debian and you feel compelled to share it with others? Knock up a longer editorial article and send it to the editors.

    General feedback should be sent to staff@debianplanet.org

    IRC
    The place to get help on a Debian problem (after reading docs) or to just chat and chill is #debian on irc.oftc.net.

    Many of the Debian Planet staff live there so pop by and say hello.

    Debian Planet also has its own channel on the same network called #debianplanet.

    Sponsorship

    DP is sponsored by Xinit Systems.

    Domains paid for and hosted by uklinux.net.

    Buy your Debian merchandise at DebianShop.com.

    Donate
    Support Debian through Bytemark Hosting. At least £7 will be given for each new account

    Syndicate
    XML

    libstdc++ broken, breaks apt
    Submitted by Netsnipe on Thursday, November 14, 2002 – 05:31
    PackagesBe warned that libstdc++2.10-glibc2.2 (1:2.95.4-14) in unstable breaks C++ support due to a single file being renamed. This totally renders among other things, apt-get and mozilla-based browsers, unusable. A critical bug report has been filed at #169032.

    DanielS: KDE, too. If things are snafu for you, read on, there are two fixes.

    If you’ve already upgraded to 2.95.4-14, two fixes are available (the hack and the real fix):

    • /usr/lib# ln -s libstdc++-3libc6.2-2-2.10.0.so
      libstdc++-libc6.2-2.so.3
    • Install libstdc++2.10-glibc2.2 2.95.4-11 manually with dpkg (note: that link is to the i386 deb).
    Category: News

    Control panel

    Comment viewing options:



    Select your prefered way to display the comments and click ‘Update settings’ to activate your changes.

    Subject: Workaround
    Author: gpatters
    Date: Sunday, 2002/11/17 – 19:10
    I looked for and installed:

    bonobo-activation_0.9.6-1_i386.deb libbonobo-activation4_0.9.6-1_i386.deb

    They were available off the debian mirrors under testing. I can now login but dselect complains about needing newer versions of these packages for other packages. However, most things still seem to work fine.

    Thanks for posting this fix!

    [ return ]

     

    Subject: Re: Workaround
    Author: nimrod
    Date: Sunday, 2002/11/17 – 21:00
    To fix the dependency errors, get:

    libbonoboui2-0 2.0.3-1
    libbonoboui2-common 2.0.3-1

    [ Please login, or register ]

    Search articles



    Category
    ·News (213)
    ·Features (3)
    ·Site News (9)
    ·HOWTOs (42)
    ·Tips (8)
    ·Opinion (12)
    ·Q & A (18)
    ·Sponsorship (1)

    Log in
    Username:

    Password:

    Remember me

    » Register
    » New password

    Debian Security Announcements
    DSA-402 minimalist
    DSA-401 hylafax
    DSA-400 omega-rpg
    DSA-399 epic4
    DSA-398 conquest
    DSA-397 postgresql
    DSA-396 thttpd
    DSA-395 tomcat4
    DSA-394 openssl095
    DSA-393 openssl

    Latest poll: Should deb files have built-in signatures (similar to rpm)?
    Yes, existing Release signatures are not sufficient
    Yes, these would be nice even though we already have Release signatures
    Yes, but what’s a Release signature?
    No, existing Release signatures are sufficient
    No, don’t know/care

    home · archives · news feeds · about · polls · search · sections · user account

    Powered by the amazing Drupal

    Debian Planet is not officially related to the Debian Project.
    Debian and the Debian logo are trademarks of Software in the Public Interest, Inc.